No tf data of laserscan from summit

In the project 6. Navigating summit, the tf tree that I have has no tf data from the laser published. My tf tree can be seen here
I know that tf can be published using the static transform publisher but I don’t know the correct values to give as arguments.
I would be grateful for any help

Hey, bro.
I encountered the same problem, when I launch the launch file.

I got this warnning:[ WARN] [1580569512.064864487, 454.818000000]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.gmapping.message_notifier] rosconsole logger to DEBUG for more information.

If you have any clue, please let me konw.

I have the same error.I did not have the error the last time I tried to do this. Let’s hope the problem is resolved soon

Hi @hrushikesh.kyathari and
what you are indicating is not correct. The laser is published on the topic /hokuyo_base/scan. This topic is publishing laser data on the frame (TF) named summit_xl_a_front_laser_link.
Then, as you can see in your published TF tree, there is a transform from summit_xl_a_front_laser_link to summit_xl_a_odom.

So your problem is not there. What is exactly the problem that you are having?

1 Like


Thanks for your kind reply! Here is my steps to show the problem. I followed the project 6

1 Like

Thanks, sir, I am now able to generate the map correctly.
The mistake I did was I did not change the LaserScan topic in RVIZ. probably you should change your base_frame and odom_frame parameters to:

param name=“base_frame” value=“summit_xl_a_base_footprint”/>
param name=“odom_frame” value=“summit_xl_a_odom”/>

I hope it helps.


Thanks @hrushikesh.kyathari! It works!

1 Like

Upvote this! I had the same issue and this fixed it! Also to any RIA staff (@rtellez) , there is a typo in the step 1.3 solution for the summit mapping challenge with a parameter:

I believe it should say update. It will work since there is a default value I think. Thanks everyone!