Not able to launch data collection in simulation

I think I’ve followed all the necessary steps, however when I launch start_collision_avoidance_data_collection.launch I get the following error:

process[simplegui_node-2]: started with pid [5601]
Traceback (most recent call last):
  File "/usr/lib/python3.6/tkinter/", line 37, in <module>
    import _tkinter
ModuleNotFoundError: No module named '_tkinter'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/user/catkin_ws/src/my_catkin_ws_python3/src/my_ignisbot_collision_avoidance_pkg/script/", line 7, in <module>
    from tkinter import *
  File "/usr/lib/python3.6/tkinter/", line 39, in <module>
    raise ImportError(str(msg) + ', please install the python3-tk package')
ImportError: No module named '_tkinter', please install the python3-tk package
[simplegui_node-2] process has died [pid 5601, exit code 1, cmd /home/user/catkin_ws/src/my_catkin_ws_python3/src/my_ignisbot_collision_avoidance_pkg/script/ __name:=simplegui_node __log:=/home/user/.ros/log/23439d82-77d2-11ec-9737-0242ac190008/simplegui_node-2.log].
log file: /home/user/.ros/log/23439d82-77d2-11ec-9737-0242ac190008/simplegui_node-2*.log

I believe this is due to missing packages, but when I try to sudo apt-get install python3.6-tk I also get an error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  tix python3.6-tk-dbg
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 705 not upgraded.
Need to get 74.8 kB of archives.
After this operation, 165 kB of additional disk space will be used.
Err:1 xenial/main amd64 python3.6-tk amd64 3.6.12-1+xenial1
  404  Not Found [IP: 80]
E: Failed to fetch  404  Not Found [IP: 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I tried to run sudo apt update, but that did not resolve the issue.

Is there anything I can do to fix this?
Or another solution, can I set up the simulation on my own machine? How would I go about doing that?

I got same problem too. And still no any solution for that?