Problem running the real robot

Why when I have connected to the real robot and want to move the real robot (turtlebot) around using the joystick, it says that “joystick needs rosbridge to work” and I can’t move the real robot?

I’m not sure what’s the meaning of “gamepad disconnected”?

Hello @chengshuan0000 ,

Thank you for the screenshots, it helps us a lot to debug the problem.

It is clearly a problem inside the robot scripts, that should have launched the rosbridge mentioned and the other services like laser scan, odometry and tf matrix, that are red in the left side.

We are investigating the issue. In the meantime, we can provide you more sessions to work with the lab, so you don’t need to wait to book another one. When is the best day and time for you?


Thank you for your reply. I have time to work with the lab at around 3 p.m. in the next few days. My time zone is UTC +3.
By the way, I want to ask how many times can we book the lab sessions for one week and how it is counted? Because I only used my two times of 25 minutes of lab last Sunday but I can’t book one more session this week and it says that “You already have more than one booking for the given week”.

Hi @chengshuan0000 ,

You can only book twice per week.

I created a booking for today (sorry but it’s already late for the time you asked) at 17h+03
And 3 other bookings at 3 p.m. UTC+3, as you requested.

Let me know if you can see the bookings in the RRL page and if the times are correct.

Keep me updated about the robot status, I want you to use the robot with the best experience!


I can now see the bookings in the next 3 days, and the time is correct.
I wasn’t online two hours ago, so I didn’t use the lab at 17:00, but it’s fine to have three more times this week.
I’ll update after I try the real robot tomorrow.

1 Like

Great, let us know any problems you may have so we help you


You can see from the pictures below that it still says that “gamepad disconnected”.
It seems that I can move the joystick, but the live videos cannot be loaded


Hi @chengshuan0000 ,

This message means that you don’t have a gamepad connected (a physical one).

Anyway, the cameras were really having issues, we are working on that.

The cameras still can’t be loaded.
Please tell me if it is fixed so I can try again

Is the problem about the live cameras fixed?

I am having the same issue connecting to the real robot lab. I am having a presentation for getting the certificate this week and would like to verify some issues I was having with the robot because the odom topic was giving back zeros (by echoing the /odom topic).

Hi Tomas,

I will look into this issue and give you an extra slot once solved.

Thanks and sorry for the inconvenience

1 Like


Thank you. The connection problem was solved. I still see 0 in the /odom/pose array:

can it be something I am doing wrong?
Thank you!

Currently suffering from the same issue. Any solutions will be greatly appreciated

Hello, I’m suffering from the same issue. Nothing works right now. Is there any solution to this problem.

Hi, I apologize for the issues you had. I just tested the connection and it is up and running. I will give you an extra reservation so you can make up for the lost one.

1 Like

Hi, today I had a session on the real robot lab but I couldn’t do anything. Apparently there is a problem with the robot as the connection didn’t established. On the shell a simple rostopic list would say that is unable to communicate with master sometimes. The status leds were most of the time red.

Hi. I just tried to do the real_robot pub_sub example. Everything appeared to connect correctly. The Status indicators were green and ‘rostopic list’ seemed to work.

The problem was that the lights in the room appeared to be turned off. I could see a couple of faint green leds and a flashing red/orange led. But otherwise, everything was too dark to see.

Hi @davef, thank you for letting us know. There was a malfunction with the lightsource timer. I will give you an extra reservation to make up for the lost one. I apologize for the inconvenience.

Thanks, At least I had an excuse to explore the real robot studio looking to see if I had to configure the camera or turn on a light switch.