Problem with grasping program (Fetch)

Hello, in the unit 6 there is exercise 6.2 that shows how to perform a pick and place of a cube using Fetch. The problem is that when I try to execute the .launch script in order to reproduce the same thing. The robot gets stuck in a position with this given error:
“[ERROR] [1615984098.663247, 332.234000]: Pick failed in the planning stage, try again…”
The program continues to plan a motion, but it cannot move the arm from the stuck position.
I have tried to move the little block around but the situation does not change.
Since it was a simple copy-paste exercise I don’t think to have made some mistakes in this direction.

Here I attach the picture of the arm position when the robot gets struck and the picture of the error that is repeatedly appearing in the shell (it is changed from the one I was receiving this morning even tough I didn’t touch lines of the code


UPDATE: problem solved.

Hi @VincenzoScamarcio, any chance you remember what you had to do to fix this issue? I’ve been fighting the same issue for a while now.

Hello @justin.smith ,

I’ve just replied to the other post you created.

Not sure, but I am having the same problem.

Is there a reason the solution to the demo is secret?

First the robot arm got stuck in the upright position like the image above.
I reset the simulation and the robot arm hit the table and turned the robot so it couldn’t see the block anymore.


Did you restart ythe whole simulation or just the poses? I recommend you to restart the whole simulation. There is a button on the Wimulation window that states that. Try that

Thanks for the reply.

Yes, I have reset the simulation multiple times. Also logged out and logged back in. Tried running with Rviz and with out Rviz.

The steps that I am using:
rosrun gazebo_ros spawn_model -database table -model table -sdf -x 1.30 -y 0 -z 0
rosrun gazebo_ros spawn_model -database demo_cube -model grasp_cube -sdf -x 0.65 -y 0.15 -z 1.07
roslaunch fetch_gazebo_demo move_torso.launch
roslaunch fetch_gazebo_demo move_head.launch

Now everything is ready. Then I start the pick and place script:
roslaunch simple_grasping pick_and_place.launch

Am I missing a script or setup?

Any other ideas?

Hello @matt2 ,

The set up looks correct, as long as you are launching all the required nodes in the pick_and_place.launch file, which are:

  • Moveit (move group + RViz)
  • Perception node
  • Your pick & place script

Are you getting any error messages while running your programs?