Quiz grade doesn't load

I have tried to get my services_quiz graded multiple times now and it keeps getting stuck at the 6 point mark. I have refreshed and tried again twice and have signed out and back into my account multiple times. Is this normal? Any help is appreciated.

@bayodesegun can you take a look?


Which specific quiz? No, it’s not normal; a rough guess is that you might have created an infinite loop somewhere or your code is otherwise confusing the grader. Could you please check that?

Please also check that you have not missed any of the instructions given for the quiz? (file and node names, what should be running, etc)

This is for the services_quiz. I have ran my code myself multiple times and there are no infinite loops and everything works fine. Also, the file names are all correct and there are no specified node names. I have tried running the quiz grader 5 times now and I see my robot moving but then when it stops, the quiz grader doesn’t. Could you please take a look?


I have checked your code.

On the last line of your service client code, you have:


This causes the service client to run forever, after finishing the calls. I commented this line out and was able to complete the submission for you. You may try submitting it again to verify.

Read about rospy.spin() here: What is rospy.spin(), ros::spin(), ros::spinOnce(), and what are they for?



  1. Actually that step where it’s getting stucks takes some time, because that’s where the robot is performing the squares, so give it some time (go grab a coffee :slight_smile:).
  2. Ensure nothing is running in the shell before starting the autocorrection.