Real Robot Lab Booking Error


This week on Tuesday Evening and Wednesday early morning I used 2 slots to test on the real robot.
Unfortunately the camera was not loading then and the joypad was not working. I tried to connect multiple times but wasn’t able to get a good connection, so I couldn’t test anything.

I tried now to to another booking session, but got the message “that this week I used all my bookings”. Sorry I forgot, that there are only 2 bookings possible per week.

So I wanted to ask if it is possible to get 2 more bookings, since I could not really use them this week?

I don’t know what was the problem on Tuesday and Wednesday, if there were issues with the robot or my rosject. Bc 2 week ago the connection worked fine.

So I don’t know if there is maybe a possibility to see the status of the robot lab, to know if maybe there is currently an issue, so we don’t use bookings for nothing.

Thanks in advance

Sorry for that glitch.

I have assigned you two more bookings. If you have any problems when connecting, please contact us immediately before using the other booking.


Ok thank you!

Hi @bayodesegun

So I tried to connect again, but it is still not working.

You can see in the video that the stream is loading forever.

But the robot says it is connected.

I also tried to use 2 different internet connections (one WLAN and then with Hotspot from the mobile phone). Then I also tried with 2 different laptops. To see if anything of this causes the problem.

But it still doesn’t work.

I also tried to start the rviz to see if maybe the laser recording shows something, but also here nothing happens.

So could you please help me, so that I am able to get a good connection with the robot.
I don’t know what the issue could be.

Is there something wrong with my rosject?


There is nothing wrong with your rosject, I apologize for the issues.

It seems like there was a power outage that affected the robot.

I will let you know when it is back online

The robot is back online

Hi @roalgoal

I did another attempt.

The camera was not loading.

When I started rviz, you get at least a feedback from the laser scanner:

With the joystick it was possible to move the robot a bit.

Then after a while also rviz shutdown with this message:

So it is still not possible to test anything.

We had another power outage, and the cameras lost their connection. I restarted your slots. I’m sorry for the inconvenience

Hello @roalgoal

I still have the problem that whenever I am trying to test with the robot. The camera does not work.

It is very frustrating since basically of the around 8 times I tried to book the robot session, it only worked twice.

And since I can only book 2 times a week, I am not advancing at all with the project. So I don’t know how I will ever be able to finish the project, if I can not test with the robot.

It looks like something in your system/browser/connection is blocking the cameras. Are you behind a NAT or firewall?

If possible, could you please try another browser, PC, or network, in that order? Then we can pin down what exactly is causing this error.

I have reset your bookings, so you can book another slot.

Hi @bayodesegun

Your assumption seems to be right. I tried on another PC and it worked. So like you said, it seems that something on the PC is blocking the connection with the camera. But I couldn’t figure out what exactly it might be.

Well anyway now that I finally found a way to test, would it be possible to again reset my bookings so I could get a few more trials for this week? That would be really great.

Thanks in advance