Real Robot Lab - doesn't show robot


I booked two sessions for the turtlebot3 robot. But when I ran the related rosject and connected to the robot, there was no video stream of the environment and the robot, and there was only the joystick. However, I was able to get robot data and visualize it in RViz.
Now I can’t book any session for this week.

what is the problem?

Let me see what may be happening and come back to you

Hi @m.haghbeigi the cameras for the Turtlebot3 are back again. There was a disconnection of the computer that streams the camera.

You can now book again the lab. I have set to zero the counter of booked sessions for this week so you can book again.


Still I don’t have any video of the robot and environment.

when I run the rosject, at first, it gives this message:
" No gamepad connected. You can use one to send commands to the robot."

Hi @m.haghbeigi
I apologize for the inconvenience. For some reason, the camera streamer decided to shutdown again.
This is very unusual error, never had it before.

Now, the cameras are live and streaming so you can go and use the real robot lab.

As for the error, there are now several people of the team monitoring this along today. Also we are testing to see where the error may be and push a fix along today.

Please accept my apologies and do not get discouraged in your ROS tests. Please try again, we are adding a couple of more sessions to your user so you can double the practice this week.

Let me know if you have any questions or doubts.

P.S. As for the message no gamepad connected... that is a message that indicates that you have not connected a gamepad to your computer in order to move around the robot. You don’t need to, since we provide the web-gamepad to manage the robot, but some people prefer to use an actual gamepad to command the robot. You can discard that message if you don’t want to use the real gamepad and use only the web-gamepad


Thanks for your reply. This time everything was fine until the robot stopped moving in the middle of the session.

Could you please try again? Perhaps this was when we had to reboot everything that day.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.