Real robot turtlebot - Not publishing to scan topic


I tried the real robot (TurtleBot), and it looks like the robot is not publishing to the /scan topic.

I’ve tried the command:

ros2 topic echo scan

And nothing is being published.

Screenshot for reference

Hi @marciocosta, thank you for reporting the issue. I am investigating the cause and will get back to you shortly.

Apologies for the inconvenience.

I can’t recieve from /scan too.

Hi is there an update on this?

I tried today and there is no “scan” topic.

Hi @marciocosta, that is strange, since the lidar was changed there have been no issues. I see that it says “Reconnecting” and the only one topic is present, maybe you were not actually connected to the robot and the camera somehow stayed opened?

Please, try again. I am certain you will have no issues this time.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.

Hi, @marciocosta , @mds1990 and @roalgoal

We are now detecting when this problem happens.

When it happens, you should now see a yellow badge with instructions to disconnect and connect to the robot again, like in the image below.

In any case, please let you know if you still find this issue around at any point in time.



I still not receiving datas…

Hi @mds1990,

Thank you very much for letting us know that you are still unable to get topics.

THe next time you run rostopic list and it fails, can you also run the following command before taking the screenshot?

cat /etc/hosts

This would help us diagnose it further.