Robot doesn't move in exercise 3.3

Hi, when I tried to launch the launch file call_bb8_move_custom_service_server.launch, it stuck at process[service_move_bb8_in_circle_custom_client-1]: started with pid [21204]

The code for launch file is:


When I checked with solution, I found that the title names are different from the hints and in the launch file, the type you use is, shouldn’t it be if follows the solution’s title?

    <node pkg="unit_3_services" type="" name="service_move_bb8_in_circle_custom_client" output="screen">


Hi @youngyangcs,

I’m sorry that you’re having problems with the exercise. No, the names don’t have to be the same, just that everything has to be done correctly.

In order to be able to help, please let me get a better understanding of the problem:

  • Could you please share some screenshots or code snippets or (terminal output) showing the problem and any error messages?

PS: to share a code snippet or terminal output, put three tildes (```) on a separate line, paste your code/terminal output below it and then put another three tildes at the bottom. I edited your launch file code above as an example; please check it.

The client. py:
indent preformatted text by 4 spaces

#! /usr/bin/env python
import rospkg
import rospy
from my_custom_srv_msg_pkg.srv import MyCustomServiceMessage, MyCustomServiceMessageRequest

rospy.init_node('service_move_bb8_in_circle_custom_client') # Initialise a ROS node with the name service_client
rospy.wait_for_service('/move_bb8_in_circle_custom') # Wait for the service client /move_bb8_in_circle_custom to be running
move_bb8_in_circle_service_client = rospy.ServiceProxy('/move_bb8_in_circle_custom', MyCustomServiceMessage) # Create the connection to the service
move_bb8_in_circle_request_object = MyCustomServiceMessageRequest() # Create an object of type EmptyRequest

# BB8CustomServiceMessage
float64 side       # The distance of each side of the circle
int32 repetitions    # The number of times BB-8 has to execute the circle movement when the service is called
bool success         # Did it achieve it?

move_bb8_in_circle_request_object.duration = 4

rospy.loginfo("Doing Service Call...")
result = move_bb8_in_circle_service_client(move_bb8_in_circle_request_object) # Send through the connection the path to the trajectory file to be executed
rospy.loginfo(str(result)) # Print the result given by the service called

rospy.loginfo("END of Service call...")

The launch file: call_bb8_move_custom_service_server.launch

    <node pkg="unit_3_services" type="" name="service_move_bb8_in_circle_custom_client" output="screen">


Terminal Screenshot:

Sorry is my probelm, I forgot to run the strat_move_bb8.launch at first.

1 Like

Hi, youngyangcs, I met the same problem. Could you please explain more about how you fixed the problem (if possible, may I also have a look at your start_move_bb8.launch file)? Thanks a lot!

Hi @baimuyi1991,

Welcome to the Community!

Please describe the problem you are facing; it might look similar to @youngyangcs’s but it might be a completely different reason.

Hi, @bayodesegun,

Thank you very much for your reply. I actually have the same problem as youngyangcs met: after I launch the launch file, the robot does not move and the same screen (please kindly refer to the screenshot that youngyangcs showed) appears. If possible, could you please have a look at my package from the following link?

Thank you in advance!

The name of the package is

Hey @baimuyi1991,
please be a bit more specific. Which service server are you launching, and which service client? Remember that the server has to be running, then in a 2nd webshell, run the client.

It works now. Thank you very much for advices! @bayodesegun, @simon.steinmann91

1 Like