Robot ignite is very slow? please fix it ASAP

Hi Robot Ignite,

I’m just trying to load some lessons , like TF101 or UDRF…, the panels just loads for ever…, the tutorial doesnt load… and the 3D plane on the corner doesnt load…, what is going on?
I dont have much time, I want to complete those courses of yours…,

I can tolerate with some errors and bugs where I had to go to unit 0 and then back to the right unit …but now it is NOT working at ALL…, already tried restarting my computer 10 times and I’m nbn connection

1 Like


Sorry to hear the issues you are having.

Could you tell us the browser you are using?
I’ve tested here with firefox and it’s working just fine.
It may be the files you have in the catkin_ws. Could you remove them and then close the browser for around 15 min and then relaunch the course again, checking those files are not longer there?
I would also suggest checking that this happens with other courses.

Also could tell us from where are you connecting? It might be a zone of the world issue.

Please contact us if it works or if it doesnt so we can give you support.

With that info hope to be able to help you solve that issue.


It’s very annoying … please fix it ASAP.

My answers to your question below

  • Which country are you connecting from? - Australia, Sydney
  • Which browser are you using? - Chrome browser
  • If you press F12 in the browser and search for console, could you print the errors you get when launching the course? - There is no errors but just continuous spinning and does not load the tutorial and takes ages to load the 3D plane (or it just wouldn’t load) on the right-hand side … it is very frustrating …

I await your resolution and updates


No … other courses I get the same issue alright …

Even the 3D plane takes ages to load up or it doesn’t load at all … stuck on the spinning wheel on the panels and I waste my time waiting for it to load …

It is very frustrating … , I want to learn the course and not just sit there and waiting for your course to load …I did pay for the subscription by the way

And it just doesn’t make sense that I have to delete all my files … I m like half way through a module … so I have to delete and do it again?? Sounds ridiculous right ? And wastes my time doing over and over again… I don’t accept this solution …

Late last night , it loads up better but during the day … it is dead slow in loading up a module or it just keeps spinning for the tutorial panel and the 3D plane panel…

Super frustrating … please fix ASAP as I really want to complete the modules smoothly this coming weekend and Today of course

Also , this load up issue is more severe during day time …, Australian Eastern Standard time

I would suggest you test it day time as opposed to night time alright ,

And check your network topology for any latencies and loss

Please rectify

I’m working on the updates you just provided and will get back to you soon.

Hi Roger,

I apologize again that you are having this issue with our platform. We are here to help you find the root cause of the issue.

First, it would be helpful if you can share a screenshot or a screencast of what you are seeing so we can get a better understanding of the issue.

Here are few suggestions on other things we can check:

  1. You are assigned a VM in your region, so your location should not be a big factor in this. However, your Internet connection speed/quality can be a big factor. Since you mentioned that this experience is worst during your daytime, could you please:
    a. Check the speed and quality of your internet connection at these different times?
    b. Try a different Internet connection, if possible?
    c. Try a different PC and/or browser, if possible?

  2. Are you behind any sort of proxy, firewall, or even VPN. These can slow down and even block your connections.

  3. Are you using any sort of ad blocker in your browser? Please have a look at the conversation below, relating to this.
    Infinite file browser/text editor loading and bad vim support in terminal

Hi @bayodesegun

Ok, I tried a different browser - firefox this morning and all the panels loaded for the module for now…, hopefully this will work now…,

As said before I’m either on NBN connection at home which is super fast or on Telstra 5G speed so that shouldnt be a problem and no I’m not behind any proxy firewall rules nor VPNs…

I dont have any ad blockers extensions on my chrome ,

Now, is there a reason that the module doesnt load properly in chrome? for example I tried loading Rosbots into gazebo this morning and I can see colors on it in Firefox but not in Chrome…, and in chrome, the tutorial panel takes forever to load but in Firefox, all panels loaded, …, so is it not compatible with google chrome?

I’m glad to hear that it works now! Thanks for the update.

It’s quite strange that Chrome isn’t working for you, as it seems to work better than Firefox for most (we officially only support Chrome and Firefox). I use Chrome. If your Chrome is up to date, then I think there could be something blocking our site in it. Please check again all the points mentioned in this thread: Infinite file browser/text editor loading and bad vim support in terminal.

ok, thanks for the help.

Hi @wai.mak,

I have been investigating this issue, and I found that our system failed to launch simulations at least twice in the day you created the issue.

The reason why it failed is that the computer was too overloaded, according to my investigation.

So to avoid this problem, what we did was to limit the CPUs that can be used by services/containers, so that one service does not affect other services.

We will keep an eye to see whether this problem happens again.

But in any case, if you still experience this error with Chrome, please let us know, and also let us know the version of Chrome so that we can investigate it even further.


Hi @ralves

ok I’m glad you are digging deep into it more into this because it is super frustrating, as I’m paying monthly subscription fee at a price and I’m not expecting this low performance issue to happen, …,

At times I get messages when loading a module that there are too many people on it and it will be slow…, I mean, dont your company have enough hardware power to maintain the service demand…??

And last night, I had to wait 20 minutes or so on just to load up a module on navigation …it happens to me few or more times a day , some times it loads and when it times out because I walked away 5 mins or something, i had to reload and it takes ages…, and sometimes when the kernel/tutorial panel crashes/spins for long time…i had to reload and wait wait wait…very time consuming, I feel very inefficient and waste…,

My chrome is up to date:
Google Chrome is up to date

Version 91.0.4472.124 (Official Build) (64-bit)

My firefox is up to date:
89.0.2 (64-bit)

they auto update anyway so its regardless what web browser, I experience this loading issue …takes ages or the simulation just comes up blank and I had to load over and over again…, its very unstable!.., and I’m just not satisfy with it! I’m not sure what others think but this is getting up my nerves especially when I trusted your academy and educate myself smoothly…,I EXPECT this to be fixed and compensate time and effort loss from my end.


Hi @wai.mak,

This happens normally when many people come at the same time. We always have at least 12 computers reserved, but depending on the peak of users, new computers have to be started, and then users have to wait. We are working on how to improve this.

I noticed some time ago that sometimes the simulation was really taking a bit longer than usual to load the assets. We will investigate how to optimize this assets loading today to improve the experience.

I would like to express that your feedback is helping us to identify the weaknesses of the platform, and we are working on improving it, so, feel free to let us know your frustrations so that the platform can become better day after day.

@ralves ,

am stuck on loading the IDE like its forever, this really needs to be improved as during this pandemic, there must be tonnes of people online studying and you need to provide a strong infrastructure in order to deliver the quality of service to your customers…,

loaded a couple of times and finally it got loaded…

1 Like

I was seeing a lot of timeouts while running one of the courses yesterday and it’s been slow to load for me too.

I’m running on Windows Edge (chrome based version) and in the UK.


I apologize for this. I think it’s related to this issue.

1 Like

I’ve just worked through a few units of a course without it happening once so a very good sign, does seem quicker too. :slight_smile:

1 Like

it is very slow today again!! please fix ASAP!..been loading for ages…


I’m sorry that it took some time before we could load your environment. Thanks for letting us know.

At the times that this happened, we had to launch new VMs for you because the current ones were full. We are working on improving this so that you don’t have to wait so long.

Whenever you have this experience, it would be greatly helpful if you can share a screenshot of what you are seeing at that time, if you can. It will help us to detect the problem faster.

If you have any other information for us, please do not hesitate to let us know.

yes sure, I will send you a screenshot next time

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.