Ros Autonomous Vehicle 101

When trying to compile I get this error.

/home/user/catkin_ws/src/rviz_satellite/src/aerialmap_display.cpp:98:45: error: ‘class rviz::FrameManager’ has no member named ‘getTF2BufferPtr’
tf_buffer_ = context_->getFrameManager()->getTF2BufferPtr();

Any idea of what to do?


Just executed the following commands in the course shell an dit gave no compilation error:

cd /home/user/catkin_ws/src/
git clone
cd /home/user/catkin_ws
source devel/setup.bash
rospack profile

Could you indicate what you did exactly? Did you download some other repo or branch? Are you executing this in your local computer instalation?

I made the gps subscriber node and tried to run catkin_make and got the following:


Could you indicate if you are doing this locally or in the course, and maybe indicate the unit where this happens and share the code you are trying to compile?

Ah, my apologies. It is in the ROS Autonomous Vehicles 101. Unit 2. We have to write scripts for navigating GPS waypoints.

Here is the link to the code I am trying to compile: GitHub - Oreoluwa-Se/Ros-Autonomous-Vehicle


Just downloaded your code and compiled and had no issue. Could you try to remove the build and devel folders and compile again? Because I couldn’t reproduce your issue:

Sorry, I couldn’t upload the rviz_satellite package.

Steps to reproduce the error:
After downloading the GitHub file, I downloaded the rviz_satelliete package as mentioned in the course
“cd /home/user/catkin_ws/src/
git clone
cd /home/user/catkin_ws
source devel/setup.bash
rospack profile”

Then I ran catkin_make and the TF2BufferPtr() error came up


I just fixes your files, you should be able to compile now. I detected that there is an issue in this rviz_satelite package that was introduced on recently. To fix it I had to download a certain branch which has this fixed. Also detected that now it needs a map frame to work , so you will have to execute this command in a shell to publish the map to odom frame so that the map works in rviz. Sorry about this issue, its difficult for us to control the thousands of packages of third parties that we use… But we are working on it ;).

Commands to fix the issue:

roscd;cd ../;rm -rf buidl devel;cd src
git clone --branch=3.0.1 src/rviz_satellite
roscd;cd ../;catkin_make;source devel/setup.bash;rospack profile

And in another shell once the rviz is running

rosrun tf static_transform_publisher 0 0 0 0 0 0 catvehicle/odom /map 100

You should then be able to move the car using this command and see how it moves around the map:

rosrun teleop_twist_keyboard cmd_vel:=/catvehicle/cmd_vel_safe

Thanks for the patience and reporting the issue.

Issue in Git: GITISSUE

Thank you for your response