ROS Basics in 5 days, Task 3, ROS Basics Exam

Hello. I was doing Task 3 from ROS Basics Exam and I encountered this error when I tried navigating back to my workspace root and build it. I also tried to launch using roslaunch basics_exam check_distance_action.launch and I got errors. I’ll attach here the errors. What can I do to fix it? Thank you.

It looks like you are not compiling your packages properly. As the error message indicated, you must compile in the root of the workspace, which is /home/user/catkin_ws. Try:

cd /home/user/catkin_ws
rm -rf build/ devel/
source devel/setup.bash

If still not working, then check that

  • you created your package in `/home/user/catkin_ws/src
  • you have made the necessary changes to CMakeLists.txt and package.xml

Sir, I did compile in the root of the workspace. When i got the error, I used the exact commands you mentioned. Then when it still didn’t work I redid everything step by step making sure I don’t forget anything. I made the changes to CMakeLists.txt and package.xml.

I suppose it’s working now?

No sir. I meant that even though I did everything you mentioned it still doesn’t work. I did everything you said a few times over several days and nothing changed. Is me using a Macbook to do these tasks influencing in any way?

This problem is similar to what you have in the following post (your messages are not built yet).

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.