ROS Basics In 5 Days -Unit 6- rosservice call /my_service [TAB]+[TAB] shows no output

rosservice call /my_service [TAB]+[TAB]

File “”, line 1
rosservice call /my_service [TAB]+[TAB]
SyntaxError: invalid syntax

Hi @shrirangsp,
Welcome to the commuity :slight_smile:

This is not meant to be executed directly. You are supposed to type:
rosservice call /my_service
in the Terminal and then press [TAB] on your keyboard twice to autofill the rest of the command.

Thank you @simon.steinmann91

I has pressed [TAB] button twice and I got that error.

can you post a screenshot?


I cannot see /my_service anymore
But /move_bb8_in_circle that i tried worked perfectly.

Make sure that your service server is running.

Please read the instructions care fully , it works as shared in Example 5.4 section .
For Demo use below 2 commands only
Shell#1 : roslaunch trajectory_by_name start_service.launch
Shell#2 rosservice call /trajectory_by_name “traj_name: ‘get_food’”

Output on the shell will be like this

rosservice call /trajectory_by_name “traj_name: ‘get_food’”

success: True

status_message: “Successfully executed trajectory”

Robot Arm should also move

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.