ROS basics Unit 3 cannot launch the first simulation


Cannot locate package and file to run the first simulation using command:

roslaunch iri_wam_gazebo main.launch

Error message:
[main.launch] is neither a launch file in package [iri_wam_gazebo] nor is [iri_wam_gazebo] a launch file name
The traceback for the exception was written to the log file

I also looked into the Code editor and there are no files in simulation_ws → src (an analogy made by Unit 1). Seems like files are missing.

Thank you!

There are 3 ROS Basics courses. Which one are you talking about?

1 Like

I am going through “ROS Basics in 5 days” (in python) book and the link to the project is



Was able to find a working link, now the files are present in a repository in order for me to run the simulation

BUT, I still can’t run the simulation.

I checked the rights to execute both files for Gazebo and aff and they are present

are you saying this is from a book?

yep, I tried both

  1. the book version - roslaunch iri_wan_aff_demo start_demo.launch

  2. and the “Notebook preview” line from the website - roslaunch iri_wam_gazebo main.launch

same error

Looking at the ROSject, it seems it is from the old version of the construct sim stuff (2 years old). It may have been overlooked or you may need some help from the guys who made it.

Learn Robotics from Zero - Robotics & ROS Online Courses – This one should be the same, but works (there is a size difference). You also may want to delete that other rosject before you try this one. Hope you learn a lot!

1 Like

Thank you a lot! The link works and seems to have all the necessary files to complete the Unit. When you say “there is a size difference”, what do you mean?

I went and seen who made the ROSject that you had linked. Then I looked at the other ROSjects that they had made. I seen that there were two name the same thing, but one had a larger file size. The larger one is the one that seemed to work. I believe the issue is that the link was made before the RIA stuff got updated–just my best guess.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.