ROS IN 5 DAYS Noetic, rospack, catkin_make command not found

Hello, I completed the ROS in 5 Days in the Kinetic version of the course and now it has been updated to Noetic; however, when I tried to resubmit the quizzes for the newer version I am now getting that the command rospack is not found.

Actually, catkin_make also does not work

1 Like


Actually, no ROS command is working. I have looked in ~/.bashrc and ROS noetic is not sources by default and even when I source “source /opt/ros/noetic/setup.bash” and try to run the commands I am still unable to run anything.

Things seem to be working now

1 Like

Hi @Marius

Thank you for your feedback. I apologize - at some point, things were not working yesterday while we prepared the course for the final migration from Kinetic.

Please let us know if anything else is not working.

1 Like

I have the same problems today all day.

maybe try running the command: echo “source /opt/ros//setup.bash” >> ~/.bashrc
and then to restart the current terminal: bash

Hi, please give us the details of the error you are having. Which unit, which exercise/example. A screenshot would be extremely helpful.

it started yesterday with this unit. I wrote my launch file and I couldn’t run it. Today it couldn’t load the simulation and roslaunch still doesn’t exist.


So I just executed it and it worked. So it must have been some isue related to have opened the Noetic course yesterday. We deativated them due to some issues that were detected.

Could you do the following:

  1. remove all the buidl an ddevel folders of your catkin_ws and recmpile it like so:

    cd ~/catkin_ws
    rm -rf build/ devel/
    source /home/simulations/public_sim_ws/devel/setup.bash
    source devel/setup.bash ;rospack profile

Now you should be able to do roslaunch, rostopic or whatever commands of ros.
Now just change to a unit of the course that changes the simulation ( Unit8 for example)
And return back to this Unit9.
The simulation should launch correctly.
If not please tell us