ROS in 5 Days Topics Quiz grading

I have completed the topics quiz for unit 4 of ROS in 5 days but it keeps giving me a mark of 1. I have tested out the program multiple times and I do not understand what is wrong. I can see in the simulation that the robot avoids the wall and when I do rostopic echo /cmd_vel, I can see information being published to the topic. However I keep getting zero marks for these. Can someone please help me? I am so lost and my professor doesn’t understand my mark either.

Hi @joubr13,

  1. Can you run catkin_make successfully? When I tried it didn’t complete because of an error.
  2. Can you run roslaunch topics_quiz topics_quiz.launch successfully? Here’s what I got when I tried:
user:~$ roslaunch topics_quiz topics_quiz.launch
... logging to /home/user/.ros/log/559216fa-0e02-11eb-be1b-0242c0a82008/roslaunch-6_xterm-1307.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Invalid roslaunch XML syntax: no element found: line 8, column 4
The traceback for the exception was written to the log file

With these errors in place, it’s not surprising that the quiz is failing.

Next steps:

  1. Please fix the errors above and any that comes up. You need to test your code using roslaunch, not just run the python code. And, of course, your package needs to compile.
  2. Please check that you have created the package exactly as specified. Otherwise, the grader could mark you down even if your package works.