ROS Navigation Course Project not working


when I am using the command

roslaunch realrobotlab main.launch

I am getting the error

Resource not found: turtlebot3_gazebo

How can I fix this? I am using the Edge browser on Windows.

Hi, I tried “roslaunch realrobotlab main.launch” in the ROS Nav in 5 days, Nav for ROS2, sensor fusion, RTAB, and TEB, and none worked. So then I noticed that in “Localization” section (Unit 3), it tells you to use the Construct sim portion.

I followed the instructions as it is on the course ipynb, but had the same results as you. I was able to load the world minus the turtlebot by selecting a simulation, choosing the turtlbot3, an empty world, and then running roslaunch realrobotlab main.launch. I am going to try this different ways to see if I can make it work. Good find buddy!

While messing with it I learned how to make it more unfunctional.

Hello @Flix17 ,

I just tried copying the Navigation rosject and it’s working for me. However, seeing your error, it looks like in your case it’s not able to find the turtlebot3 packages. Could you try sourcing the simulation workspace?

source ~/simulation_ws/devel/setup.bash

Hello @albertoezquerro,

unfortunately this did not work. I even deleted the whole project and copied it again, but I get the same error.

Hi, I’m sorry you’ve ran into this issue. I’ve updated the rosject that you get from the course, so if you could delete the one you forked previously and click on the link again, you should not have that problem anymore.

1 Like

Thanks @roalgoal. I was just having the same issue and this worked.

@roalgoal As I’m working through this I notice that the issue with keyboard_teleop seems to be broken again. This was previously fixed by @albertoezquerro (see this thread: )

I’ve tried running what I think should be the correct command:
roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch
But I get an error message:

process[turtlebot3_teleop_keyboard-1]: started with pid [3928]
Traceback (most recent call last):
  File "/home/user/catkin_ws/devel/lib/turtlebot3_teleop/turtlebot3_teleop_key", line 7, in <module>
    with open(python_script, 'r') as fh:
FileNotFoundError: [Errno 2] No such file or directory: '/home/user/catkin_ws/src/turtlebot3/turtlebot3_teleop/nodes/turtlebot3_teleop_key'

Looks like there is a missing set of Turtlebot3 files that are supposed to be in /home/user/catkin_ws/src. Were these files perhaps inadvertently removed when removing the other files in src that should have been removed (see this thread)?


Hi, thank you for bringing this up. I’ll look into this now.

I still can’t do mapping in the ROS Navigation in 5 Days Rosject.

The project notebook still says to use roslaunch turtlebot3_telep keyboard_teleop.launch which doesn’t work. Even if you fix the obvious typo and try “turtlebot3_teleop” it doesn’t work. Looking at the simulation_ws, there is a file turtlebot3_teleop_key.launch,

After googling I see that since that’s in a different workspace, I would need to change workspaces, which is what @albertoezquerro was getting at. If I do that, I still get an error when I run
roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch

FileNotFoundError: [Errno 2] No such file or directory: ‘/home/user/catkin_ws/src/turtlebot3/turtlebot3_teleop/nodes/turtlebot3_teleop_key’

Not sure why I get that since I just sourced the simulation_ws.

Would be nice to get a fix (or workaround) to this so I can get on with the project.


Hi, I think the reason you are having that error is because the system is looking for the turtlebot3 package in the wrong place (catkin_ws - this was a previous fix, my error, and your rosject version might have been not updated), something that can be fixed by either removing your build/ and devel/ folders in your catkin_ws and compiling again, or by updating the rosject you have by clicking on the red “i” button at the bottom right of the rosject. I have tried the rosject that is obtained through the link in the course and the teleop works fine.

You can also delete the rosject fork you already have and get it again from the course.
(or from here, this is the same rosject link: Learn Robotics from Zero - Robotics & ROS Online Courses)

Let me know if this still doesn’t work, sorry about this.


Thanks for the suggestion @roalgoal. Deleting the build and devel folders in my catkin_ws and then running catkin_make worked.

1 Like