Ros navigation in 5 days part3 project

why i am keep getting that error
can someone help me to know if there an error in my parameter files

[ WARN] [1679180568.133678988, 144.389000000]: DWAplanner failed to produce path.
[ WARN] [1679180568.419302171, 144.588000000]: Rotate recovery behavior started.
[ERROR] [1679180568.419462480, 144.589000000]: Rotate recovery can't rotate in place because there is

these are my files


obstacle_range: 3.0
raytrace_range: 3.5
footprint: [[-0.105, -0.105], [-0.105, 0.105], [0.041, 0.105], [0.041, -0.105]]

publish_frequency: 1.0

  inflation_radius: 0.5
  cost_scaling_factor: 3.0

  observation_sources: scan
  scan: {sensor_frame: base_scan, data_type: LaserScan, topic: scan, marking: true, clearing: true}


# Robot configuration parameters  
acc_lim_x: 2.5
acc_lim_y: 0
acc_lim_th: 3.2
max_vel_x: 0.5
min_vel_x: 0.0
max_vel_y: 0
min_vel_y: 0
max_vel_trans: 0.5
min_vel_trans: 0.1
max_vel_theta: 1.0
min_vel_theta: 0.2
# Goal Tolerance Parameters
yaw_goal_tolerance: 0.1
xy_goal_tolerance: 0.2
latch_xy_goal_tolerance: false


global_frame: map
rolling_window: false

  - {name: static,                  type: "costmap_2d::StaticLayer"}
  - {name: inflation,               type: "costmap_2d::InflationLayer"}


global_frame: odom
rolling_window: true

  - {name: obstacles_laser,           type: "costmap_2d::ObstacleLayer"}
  - {name: inflation,                 type: "costmap_2d::InflationLayer"}


controller_frequency: 1.0
recovery_behaviour_enabled: true

  # Robot Configuration Parameters
  acc_lim_x: 2.5
  acc_lim_theta:  3.2

  max_vel_x: 1.0
  min_vel_x: 0.0

  max_vel_theta: 1.0
  min_vel_theta: -1.0
  min_in_place_vel_theta: 0.2

  holonomic_robot: false
  escape_vel: -0.1

  # Goal Tolerance Parameters
  yaw_goal_tolerance: 0.1
  xy_goal_tolerance: 0.2
  latch_xy_goal_tolerance: false

  # Forward Simulation Parameters
  sim_time: 2.0
  sim_granularity: 0.02
  angular_sim_granularity: 0.02
  vx_samples: 6
  vtheta_samples: 20
  controller_frequency: 20.0

  # Trajectory scoring parameters
  meter_scoring: true # Whether the gdist_scale and pdist_scale parameters should assume that goal_distance and path_distance are expressed in units of meters or cells. Cells are assumed by default (false).
  occdist_scale:  0.1 #The weighting for how much the controller should attempt to avoid obstacles. default 0.01
  pdist_scale: 0.75  #     The weighting for how much the controller should stay close to the path it was given . default 0.6
  gdist_scale: 1.0 #     The weighting for how much the controller should attempt to reach its local goal, also controls speed  default 0.8

  heading_lookahead: 0.325  #How far to look ahead in meters when scoring different in-place-rotation trajectories
  heading_scoring: false  #Whether to score based on the robot's heading to the path or its distance from the path. default false
  heading_scoring_timestep: 0.8   #How far to look ahead in time in seconds along the simulated trajectory when using heading scoring (double, default: 0.8)
  dwa: true #Whether to use the Dynamic Window Approach (DWA)_ or whether to use Trajectory Rollout
  simple_attractor: false
  publish_cost_grid_pc: true  

  # Oscillation Prevention Parameters
  oscillation_reset_dist: 0.25 #How far the robot must travel in meters before oscillation flags are reset (double, default: 0.05)
  escape_reset_dist: 0.1
  escape_reset_theta: 0.1


allow_unknown: true # Specifies whether or not to allow navfn to create plans that traverse unknown space.
default_tolerance: 0.1 # A tolerance on the goal point for the planner.

Hi @80601 ,

I went through your config file contents and found out some mistakes:

  1. move_base_params should not have TrajectoryPlannerROS paramters.
  2. Your local and global costmap params are missing height and width parameters in both files. Set global height and width more than local height and width.
  3. Your move_base_params are missing some other params like controller_patience, planner_frequency, planner_patience.
  4. Set track_unknown_space to false in local costmap params.

= = = = = = = = = =

I suggest that you refer the documentation for these config files and use those values:

Global Planner:

Local Planner:
E-Band and TEB are not helpful for this rosject but you can try it out if you want to!

Use this reference for common_costmap_params, global_costmap_params and local_costmap_params.


Implement all the parameters in your config files. If you are not using any parameter, either set it to default value or comment it out if you are unsure.

= = = = = = = = = =

To get rid of “DWAplanner failed to produce path.” error:
Add this line in your common_costmap_params
robot_base_frame: base_footprint
Add this line to your amcl launch file or the config file - wherever you have amcl parameters.
<param name="transform_tolerance" value="5.0"/>
If the above two steps does not fix, then set controller_frequency > planner_frequency in move_base_params.

If all the above does not fix your issue, let me know.