ROS Navigation Rosject - Need Help with Path Planning Errors


I am currently doing the ROS Navigation in 5 Days course project (rosject).

I have finished Section 1 (Mapping) and Section 2 (Localization).

I am currently working on Section 3 (Path Planning). I have finished all the steps in this section. After running the simulation, I consistently get the following error [when I try to do “2D Nav Goal” on Rviz]:

[ WARN] [1672240993.169836932, 106.656000000]: Could not transform the
global plan to the frame of the controller
[ERROR] [1672240993.169903634, 106.656000000]: Could not get local plan
[ INFO] [1672240993.473685516, 106.861000000]: Got new plan
[ERROR] [1672240993.473831592, 106.861000000]: Extrapolation Error: Lookup 
would require extrapolation -0.028000000s into the future.  Requested time 
106.833000000 but the latest data is at time 106.805000000, when looking up 
transform from frame [odom] to frame [map]

[ERROR] [1672240993.473877976, 106.861000000]: Global Frame: odom PlanFrame 
size 208: map

I understand that I have some problems in my local_planner. But I am not sure what to do.

After sometime, recover behaviors are triggered and the robot does Rotate Recovery Behavior.
So, I am partly happy that my move_base node is working.

Please help!


I somehow managed to fix the errors in my local planner, but now my robot is not moving to the goal position.

Initially after setting the goal position on Rviz, I get this message (and no other error messages):

[ INFO] [1672299513.894831889, 134.851000000]: Got new plan

After few minutes time, I get the following error:

[ WARN] [1672300195.204467402, 522.650000000]: DWA planner failed to produce path.

I get the goal pose registered on the Rviz map and the global planner trajectory is also visible.
But robot never moves. Also no recovery behavior from the robot.

Can someone help me with setting the parameters or give me some hints on which are the most important parameters to “play around” with?


Hi Girish,

My guess is that something in the parameters is giving problems. I suggest you take a look at the turtlebot’s public git and check for the “base parameters” for a robot like this: turtlebot3/turtlebot3_navigation/param at master · ROBOTIS-GIT/turtlebot3 · GitHub

Maybe the controller frequency is the issue? Have you tried lowering it?

Hi @roalgoal ,

Thanks for pointing me out to the turtlebot3 repository!

I tried using the exact same parameters for the respective files [from the above github repo], but my robot still did not move too much. I think the robot tried to rotate, but very very slowly. I was not sure if it was by the move_base node or some simulation drift.

I tried lowering this parameter also. I found 2 controller_frequency parameters in dwa_local_plannar_params.yaml and move_base_params.yaml. I tried setting them to 10.0, 5.0, 2.0, and 1.0. But in all the four cases, my robot did not move. from its current point to the goal pose [which I set using rviz].

I am still “playing around” with some parameters. But as of now, I still cannot get the robot to move to the goal position.


Hi @roalgoal ,

I have finally figured out what I was doing wrong. Now the problem is solved!

I had the teleop program running where I had stopped the robot and forgot to Ctrl+C the program on the terminal. So the robot never moved after providing a goal pose on Rviz.

I eventually realized that it was teleop program blocking the robot from moving on the map!

Lesson learned:
Make sure that teleop program is stopped (terminated) on the terminal before giving the goal pose!