ROS Services Part 1: /gazebo/delete_model service does not work; /gazebo/model_states no longer working after calling the service


I think there is a bug, in ROS Service Part 1, I am using chrome.
Following the part where I delete element of the gazebo simulation using rosservice call /gazebo/delete_model

Command 1: I list the object in simulation and see the objects

user:/home/simulations/public_sim_ws/src/all/iri_wam/iri_wam_aff_demo/launch$ rostopic echo /gazebo/model_states -n1
**name: [ground_plane, cafe_table, kinect, bowl_2, bowl_1, unit_box_1, iri_wam]**

Command 2: Trying to delete the cafe table but it hangs, and I never see the table getting deleted and the bowl falling on the floor.

user:/home/simulations/public_sim_ws/src/all/iri_wam/iri_wam_aff_demo/launch$ rosservice call /gazebo/delete_model "model_name: 'cafe_table'"

Command 3: There are no gazebo/model_states anymore.

user:/home/simulations/public_sim_ws/src/all/iri_wam/iri_wam_aff_demo/launch$ rostopic echo /gazebo/model_states -n1
WARNING: no messages received and simulated time is active.
Is /clock being published?

Command 4:
Running the (example 3.5) hangs and return service time out, ie it cannot erase the bowl.

Any thoughts?

Hi Robin, we’re working on this issue and will get back to you ASAP.


This is still not working.
Just tried to complete Exercise 3.1 and I do not see anything happening. Seems it is related.
Also when I reset simulation i have
user:/home/simulations/public_sim_ws/src/all/iri_wam/iri_wam_aff_demo/launch$ rostopic echo /gazebo/model_states -n1
name: [ground_plane, cafe_table, kinect, bowl_2, bowl_1, unit_box_1, iri_wam]

HI @robinguers,

I apologize for the delay, but we’re still working on it. The issue is that sometimes it works fine and sometimes it does not, and we’re trying to pinpoint what’s failing and fix it. Thanks for your patience.

Hi @bayodesegun,

sorry to bother again but now I am trying to run

rosservice call /gazebo/delete_model “model_name: ‘cafe_table’”

but it doesn’t do anything…

success: False
status_message: “DeleteModel: Model pushed to delete queue, but delete service timed out waiting for
\ model to disappear from simulation”

Hi @valentinasoana,

You’re welcome to bother me :wink:

I apologize for the issue the Gazebo delete_model service. We know about and are working on it in this here.

We’ll let you know once it’s fixed.

@valentinasoana @robinguers,

Just wanted to let you know that we have replaced the /gazebo/delete_model/ with another example that works. Thanks so much for bearing with us.

As @bayodesegun says, we have finally replaced the delete_model exercise for another one using a different service. This is because, after some rehearsal, we finally found out that this is an internal Gazebo issue (bug), which would require too many things to be solved. Hope you find this new Demo equally helpful and, of course, if you find any other issue or you have some feedback related to it, don’t hesitate to let us know.


1 Like