ROS simulation screens are not loading

My webshells,terminals,etc. basically the whole simulation is not loading. I have tried reloading/login logout but none have worked. Anyone with a similar issue and has a fix for it?

Hey @conchimtucgian, welcome to the Community!

I’m sorry for the trouble. Could you please check the following?

  • Does your connection allow WebSocket connections, ws:// or wss://, in addition to http and https? We use WebSocket extensively for those screens.
  • Are you behind some kind of firewall or proxy?
  • Could you please try again?

Please let us know how it goes.

I have read the other forum posts and learnt that it seems to be an ON/OFF issue. Anyways i waited for a while and turned off my adblocks, seems to be working fine after that. Thank you!

Glad it’s working now!

No, it’s NOT an on/off issue. Yes, there have been times when it was a problem with the platform, but also times when it was a problem with the user’s connection or even PC. In all cases, we’re here to help.



So, Constructsim works fine only with Chrome? firefox present issues?

My best,

Hi @eblady,

It’s working in Firefox, just that it’s not working in your Firefox browser. Browsers change, and you might want to go through the troubleshooting guide indicated above to see why it’s no longer working in your Firefox browser.

We currently support Chrome, Edge, and Firefox.

Apparently in the advanced configuration of my browser the network.http.http2.websockets property was set to false. I turned on and apparently it worked.

My best,

1 Like