ROS2 Basics in 5 Days (C++): Auto grader failing - Could not launch topics_quiz package successfully

The auto grader fails to launch topics_quiz package successfully. And so it fails to do the rest of the quiz needed. I am not sure what is wrong as the names required are the same and as I can launch successfully the code with the command below: ros2 launch topics_quiz

Hi Esther,

I can see that your quiz can now be executed and that it fails later when you need to publish into the /cmd_vel

So I think you found where the error was and this issue is solved, since the Gradebot was working properly.

Thank you for getting back to me! I haven’t changed anything in the code when you replied however, the grading bot still fails me at " fails to launch topics_quiz package successfully.

My code can publish into ‘/cmd_vel’ fine and the robot avoids the sphere.
I can see it in the simulaiton when I execute it myself. I attached a screenshot of the /cmd_vel being published.

Hello @rayssiguie.esther ,

Do you have any program running when you start the grading bot? You should make sure to stop all programs you might have running before launching the grade bot.

Everything is closed when I start the grading bot.

Then I don’t understand what is happening. Can you please record a video of the whole process?
Record the full screen, show all the terminals that have no running program, then press the correction button and keep recording until the process finishes completely.

I was recording the process and it worked this time!
But I haven’t changed anything since my last reply and still started the process the same way. I was wondering if internet might affect the grading bot in some ways? As a timeout error for the grading bot? This is the only thing on my end that changed.
Thank you for your time