ROS2 navigation project

Hi everyone
I’ve just tried to start the project from ROS2 Navigation lessons. I’ve used the next instructions:

#environment setting 1
source /opt/ros/noetic/setup.bash
source ~/simulation_ws/devel/setup.bash
roslaunch realrobotlab main.launch

This image contains the output:

#environment setting 2
source ~/.bashrc_bridge
ros2 run ros1_bridge dynamic_bridge --bridge-all-topics

#environment setting 3
source ros2_ws/install/setup.bash
export TURTLEBOT3_MODEL=burger
ros2 run turtlebot3_teleop teleop_keyboard

which returns the next error:

Can anyone help me? Thanks in advance!

Hi, I don’t see the error. The terminal you are showing is the ros1_bridge establishing connections from ROS to ROS2

I think your last screenshot is not the one you wanted to share, since it contains no error. Can you please send the screen with the error?

That’s the problem.
This is the screen with the error. Thanks!

It seems like the specific teleop package for the turtlebot is out of date.

I have changed the instructions to use the generic teleop, which works. The command is

ros2 run teleop_twist_keyboard teleop_twist_keyboard

Please note that to see the changes reflected in the notebook you will have to fork another copy of the rosject

I’m getting the same error. Gazebo isn’t loading the simulation either…I don’t know what I’m missing…
Thanks again

The simulation is probably very zoomed in, just zoom out.

Check that you are getting topics in ROS2, the bridge should be showing the connections being made.

That teleop is a public package so it shouldn’t be giving that error, try sourcing ROS2 directly instead of ros2_ws, with source /opt/ros/foxy/setup.bash

That was the problem @roalgoal!!! Thanks again!!!


This topic was automatically closed after 20 hours. New replies are no longer allowed.