ROS2 workspace infected with ROS1 noetic


I keep getting a message complaining about ROS2 mixing with ROS1.

When I check the system I see it is setup for ROS1 noetic. I don’t know how I got here, but I have been trying to install things like gedit and trying to do a sudo apt upgrade which took forever and ended with errors.

How do I get back to the starting setup so I can continue with the course?
BTW the course is ROS2 basics in 5 days.



In Example 5.1 it states that you first have to execute :slight_smile:

source ~/.bashrc_ros2

In order to have the source for ROS2. Did you do that?

As for installing programs, why do you need gedit? Are you having issues with the integrated iDE?
Please tell us more about that so we can see into that issue.

Hi Rasmus,
we have found that something has been corrupted in that specific environment of yours. We are correcting it right now so you can keep working.

To clarify, for some unknown reason, your personal space for that course has been corrupted. So nothing you can do to solve it. I provided you the standard procedure to clear a regular ROS system, but given that you are using the course, and that it was corrupted in our side, that procedure doesn’t work.

I apologize for the confusion we created to you. I will let you know when it is solved

we have solved the problem.

Finally, the only thing that was wrong is that you added to the .bashrc the source of Foxy.

We have removed it and now your environment is working properly.

Please continue with your learning. I apologize for the trouble

Nice to be able to keep going :slight_smile: Thank you

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.