ROSRUN cammands not executing


When i run ROSRUN cammands it say’s no cmmand found.

Please help whats wrong with my Linux learning section 3 “Advanced utilities”


Hi Yasir,
we have checked that the command rosrun is working properly in the Linux course.

You may have a problem either in the command you are issuing or in the permissions of the file you try to execute.

Can you please post here the full command you are issuing and the full response you are getting?
If you post a screen capture will be also great.

1 Like
total 40
drwxr-xr-x 2 user user 4096 Aug 29 20:45 .
drwxr-xr-x 3 user user 4096 Aug 29 20:45 ..
-rw-r--r-- 1 user user 6786 Aug 29 20:44 CMakeLists.txt
-rw-r--r-- 1 user user   87 Aug 29 20:44
-rwxr-xr-x 1 user user   44 Aug 26 16:40
-rwxr-xr-x 1 user user  241 Aug 26 16:49
-rwxr-xr-x 1 user user  410 Aug 26 17:50
-rw-r--r-- 1 user user 2617 Aug 29 20:44 package.xml
-rwxrwxrwx 1 user user 1702 Aug 29 20:34
user@1_xterm:~/catkin_ws/src/linux_course_files/move_bb8_pkg/my_scripts$ rosrun move_bb8_pkg
bash: rosrun: command not found

Hi @shaikh.sss.shahnawaz ,

Welcome to our community.

I assume you are in the Linux course, right? If not, please try to source the catkin workspace before running rosrun:

source ~/catkin_ws/devel/setup.bash


Thank you so much Ralves, it did worked.

1 Like