Rviz error (An internal error)

Hi, I’m getting the below error for rviz. Can you please help?

An internal error has occurred within the Guacamole server, and the connection has been terminated. If the problem persists, please notify your system administrator, or check your system logs.

I also noticed this when I was using ROSDS and thought it happened only on it.


Could you please tell us the specific exercise/example you are working on? Please also specific the command you ran.


Hi, I didn’t run any command. I just opened the ROS prescription course, chapter 0 (1st page), and in the “open graphical tool” window (opens automatically), I get the below error.


Please let me know if you need additional information.

Oh, I see.

Please try again. And there’s actually a command you should run before that. If the window opens before you run the command, just minimize it and run the command.

roslaunch darknet_ros_3d darknet_ros_3d.launch

Hi, thank you very much for the reply. Unfortunately, I’m still getting the same error as above and another error in the terminal.

When you see this error, just stop (CTRL + C) the roslaunch command and try again.

Still the same issue.

I’m sorry about this. I’ve been trying to reproduce that error here but I can’t so far. :thinking:

  • Is this happening anytime you run rviz or just for this course?
  • Please close that command and run rosrun rviz rviz and see if the problem occurs again.
  • Could you please try another browser and/or PC/Internet connection, especially if the problem is happening for all instances of the graphical tool?
  1. This happens when I try to run Rviz in all of the courses and in ROSDS (Gazebo+ Rviz). As for the ROSDS, I was trying to run the RoBoX OpenManipulator repo with the following code and “roslaunch openmanipulator_morpheus_chair_tutorials start_simulation_rrl_safe.launch” and got the same error. So I cannot see Gazebo as well as RVIZ in ROSDS.

  2. I closed all of the simulations (ROSDS) and ran the command but still got the same error. As for the courses, I don’t know how to disable the situations since they start automatically.

  1. I tried to do this on both my laptop and the office PC from Firefox and Chrome. But get the same issue.

So sorry about this, let me forward this to the experts. We need to dig deeper since this is happening on both courses and rosjects.

Thank you @bayodesegun

Hi @nburdick

I was checking the logs but could see no errors in the docker container logs that are used for serving the Graphical Tools.

  • Are you using any caching/proxying tool while accessing our website?
  • If you are not using proxy, could you try using a free one just to see if the problem goes away? For Google Chrome , there is one called Free VPN for Chrome - VPN Proxy VeePN.
  • Could it be that you have a Firewall that blocks the connection? If so, could you temporarily disable the Firewall?
  • If nothing works, could you try opening the rosject using Private/Incognito mode in the Web Browser so that we can determine if it is a plugin that is breaking it?

I’m asking these questions because I could not find anything in the logs of the computer assigned to you (at least not yet), and when I tried running the same command in the rosject Open Manipulator that I forked, it loaded fine :thinking: :

Hi, Thanks for the reply. I tried all the things, but it was still not working. I tried it with a VPN and without any addons (in private mode). I’m using AVG internet security on both my office PC and the laptop, and I disabled the firewall and still not working.

Then I tried it with WSL, and it’s working inside it. So I have no idea what’s wrong. So, maybe, it’s AVG. But the site is not flagged, and I added it to AVG as a trustest website. So at the moment, I will try to work it inside WSL. Thanks.


I’m glad you were finally able to load using WSL (although I’m not sure what WSL means).

Since you are able to load it inside the Windows Subsystem for Linux (WSL), it confirms that it’s something on the PC’s primary operating system.

The prime suspect of course is the Antivirus. It’s very likely it’s something within its “Internet security” suite. Or it could be Windows Firewall itself blocking some features of the site.

Not sure which site was added to the trusted list, but it should be:

  • *.theconstructsim.com (main site)
  • *.robotigniteacademy.com (site hosting the graphical interface)

Could you try configuring the Antivirus (and Windows Firewall/Defender, if active) again and let us know?

1 Like

I turned off all the AVG services, and still the same. At this point, I have no idea what is happening.

Sorry to hear that. But don’t worry, we’ll get to the bottom of this.

What is happening is that something is blocking that app. We need to find this something and tell it to hands off!

Could you please open the browser dev tools (Ctrl + Shift + I) and show us what you see in the console before and after you open this app?

Btw, do you have an Ad Blocker?

I’m using uBlock Origin, but I ran the same tests in the private mode without any addons and got the same results.

So for the steps, you asked me to do in your last reply, I will also do it in a private window without any addons.

This is without starting the simulations

This is after running the simulation

Thank you for posting these images. They confirm that something is really blocking the connection. The wss connection shown as “interrupted” is a connection to the graphical window.

Either WebSocket connections are being blocked generally, or this particular connection is being blocked:

  • Check if WebSocket is working.
  • If working, see how you can configure your Antivirus or Ad Blocker to whitelist the domains I shared with you earlier. Working in private mode does not disable some of these software, and disabling them is sometimes not straightforward.