Service quiz-review service quiz takes a long time

hi dears, i have a problem with the review by robotigniteacademy,When I finish the questionnaire, this has been under review for a long time, even this day I have tried three times, and all three take more than two hours. So far, I have not been able to review my service quiz. help please

Hi @donoso.bravo.7,

I see that many users are reporting the same error, so it may be an error from our side.

We are going to have a look and try to get back to you in less than 24 hours.

Please give us this time to investigate it.

1 Like

Hi @donoso.bravo.7,

according to our investigation, the quiz correction gets stuck when instead of launching only the service client on call_bb8_move_in_square_custom_service_server.launch , the server is also launched.

Bear in mind that we use a specific launch file to launch the service server, and a specific launch file to launch the service client. The correct way is:

  • start_bb8_move_custom_service_server.launch has to launch only the service server
  • call_bb8_move_in_square_custom_service_server.launch has to launch only the service client.

On the notebook, we have these instructions about that, but we forgot to mention that not following it strictly could “freeze” the auto-correction:

The name of the launch file that will start your Service Client will be call_bb8_move_in_square_custom_service_server.launch ( This launch file doesn’t have to start the Service Server, only the Service Client ).

So, to solve the problem, could you double-check your call_bb8_move_in_square_custom_service_server.launch on the services_quiz package to make sure only the client is being launched?

After that, you can submit the quiz correction again, and the auto-correction should finish as expected.

1 Like