Services Quiz. Gradebot Fails to compile the package. How fix it?

Gradebot says:
Feedback from the last successful autocorrection:

:heavy_check_mark: [info] Setting up ROS2 environment (mark: 0)

:heavy_check_mark: [info] ROS2 environment setup is okay (mark: 0)

:heavy_check_mark: [assess] services_quiz package found (mark: .5)

:heavy_check_mark: [assess] services_quiz_srv package found (mark: 1.0)

:heavy_check_mark: [info] compiling packages services_quiz and services_quiz_srv… (mark: 1.0)

:heavy_multiplication_x: [assess] The services_quiz and services_quiz_srv packages did not compile successfully. Let’s fix this before we continue.
Things you can check before retrying:

  • Run colcon build --packages-select services_quiz services_quiz_srv and ensure it compiles without an error. (mark: 1.0)

user:~/ros2_ws$ colcon build --packages-select services_quiz
Starting >>> services_quiz
— stderr: services_quiz
/usr/lib/python3/dist-packages/setuptools/command/ SetuptoolsDeprecationWarning: install is deprecated. Use build and pip and other standards-based tools.

Finished <<< services_quiz [2.42s]

Summary: 1 package finished [3.27s]
1 package had stderr output: services_quiz

How fix it?

Although the packages were compiled before being submitted to GradeBot (services_quiz_srv no errors, services_quiz with a warning message but no errors).

Hello @oleg.a.kuvaev ,

As indicated in the other post, I solve this by removing the current compilation files and rebuilding the workspace:

cd ~/ros2_ws
rm -rf build install log
colcon build

Also, I saw that you had some compilation files inside ~/ros2_ws/src :

You MUST only compile in the root of the workspace /home/user/ros2_ws and nowhere else. So all the compilation folders/files that are outside the root of the workspace must be removed.

This did not solve the problem.
Packages are compiled before being sent to GradeBot. Executed by a robot.
GradeBot gives a compilation error (there are 2 attempts left, this is already bothering me a little).
What’s wrong?

Hi @oleg.a.kuvaev ,

setuptools installed in your environment is probably a wrong version.
Try the following command on your terminal:

pip install setuptools==58.2.0

Source: SetuptoolsDeprecationWarning: install is deprecated. Use build and pip and other standards-based tools. - ROS Answers: Open Source Q&A Forum

Please let us know if the problem gets fixed!


setuptools warning solved. Thank you.

Hi @oleg.a.kuvaev ,

Amazing!!! Glad that it worked for you!

I hope now you can submit your work to gradebot. Hopefully this time you won’t face any issues!


But this did not solve the global problem. GradeBot still throws a compilation error.
What’s wrong? I don’t understand :frowning:

Hi @oleg.a.kuvaev ,

Don’t panic!!! If you use up all your attempts, it can be reset by TheConstruct team.

Currently, there seems to be a problem with gradebot for this specific exercise:
Refer: ROS2 Basics in 5 Days Humble (C++) - 4.7 Services Quiz - #5 by albertoezquerro

Keep following that post to stay informed when the problem gets fixed.


Greate :smiley:
My solution for this mistake:

  1. cd ~/ros2_ws and rm -rf build install log
  2. colcon build
  3. Verify in simulations
  4. Again cd ~/ros2_ws and rm -rf build install log
  5. Sent to GradeBot WITHOUT colcon build

Profit :slight_smile:

1 Like

Hi @oleg.a.kuvaev ,

Awesome! You have found the solution yourself!

Also, thanks for sharing it!

I was about to suggest you this step. But I was slightly unsure if that would work.
Anyways glad you solved it!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.