Several RVIZ Issues for Summit XL Navigation Step 1

I am currently on the Summit XL Robot Navigation and I am having a rather difficult time getting to save the map. The order I run in each terminal is as follows:

[Terminal 1] roslaunch my_summit_mapping slam_gmapping.launch
[Terminal 2] roslaunch summit_xl_gazebo keyboard_teleop.launch
[Terminal 3] rosrun rviz rviz

When I try this, a couple things to note. First off, the RVIZ config that loads with the first .launch file (Which is the file included within the Step 1) is all wrong, giving several errors. Instead I opted to use a new config and added my own RobotModel, LaserScan, and Map. I couldn’t get the laser scan to give a viewing radius, only the ends of the walls. Regardless, I was able to move around both in Gazebo and RVIZ. However, even after running around the entire Gazebo simulation, when I tried to use the following command in my /maps directory of the project:

rosrun map_server map_saver -f my_map

I end up with new map whatsoever, no .pgm, no .yaml, nothing. Is there something that I am missing here? I saw a topic posted on April 9th about a student who was having issues with RVIZ as well, and that it would be fixed, but it seems to not be the case.

1 Like

Hello @zwlevy,

I guess you are using the RViz that is launched with the simulation, which is not properly configured. You should launch and configure only your own RViz (the one you launch in terminal 3). The one which is launched with the simulation you should just ignore it. I’ve tested this right now and it’s working properly. However, I’m going to remove the RViz session (it should be on Production by the end of the day) which is launched by default with the simulation in order to avoid this kind of confussion.


Alright, I’ve been working on my own configuration, but when I try to make a map display and subscribe to the /map topic, I get a warning: “No map received”. I think this is the reason why I am not getting my configuration to save. That being said, how do I get the map data to be published properly to RVIZ?