Simulation not loading - Waiting for

Dear Support Team,

When I try to open a course like “Python for Robotics”, the IDE get stuck trying to load. As you can see in the picture below, there is the following message “Waiting for…”.

It seems to be related to the simulation environment.

Thanks in advance.

Best regards,

Hi Pablo,

As far as I can see in the screenshot, it appears you are having problems loading the simulation (not the IDE, as you mentioned. The IDE [code editor] is the screen in the middle).

There seems to be something in your browser blocking the page. Please check:

  • Is your browser in incognito or private mode (or some other limited mode)?
  • Does your network allow WebSocket connections, ws:// or wss://, in addition to http and https? We use WebSocket extensively for those screens. You can check whether WebSocket is working here: (click the Connect button and then the Send button).
  • Is third-party JavaScript enabled for your browser?
  • Are you using an AdBlock or some strict Internet Security suite?
  • Are you behind a VPN/Firewall?

One quick test to troubleshoot is trying another browser (we support Chrome, Edge, Firefox) /Internet connection/PC you have not tried before.

Hi Bayode,

Thank you for your quick reply. Finally it was a problem related to the web socket from my laptop. It has been solved.

Best regards,

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.