Sir from where i get the gazebo environment of city of autonomous navigation

sir from where I get the gazebo environment of the city of autonomous navigation

Which environment are you talking about? Please post a picture.


Hi Ankur,
you can find the simulation you mention on our Riabot repo.

sir i am getting like this, roads and line are missing

You may be need to copy the road model to the default gazebo models path. By default its located inside the system path /home/NAMEOFYOURUSER/.gazebo/models
You can also have a look at the file package.xml that contains the model of the road and add the following line just befor the ending:

<gazebo_ros gazebo_model_path=“${prefix}/models”/>

Also check if the model used in the world is in that package because it might not be there but in another package. For that look into the world launched and look for that specific model insid ethe repo that you downloaded. Check if its there.

Hi can you explain how should we copy the model to gazebo model path. As the .gazebo isn’t accessible

Hi i tried all these steps, but i am still getting the same result


I suppose that you are working locally, am I right? I its so, you should be sure you have copied the needed folders of the models:

ln -sf ~/catkn_ws/src/riabot/duckietown_description ~/.gazebo/models/ \
ln -sf ~/catkn_ws/src/riabot/duckietown_gazebo/models/* ~/.gazebo/models/ \
ln -sf ~/catkn_ws/src/rosbots/rosbots_description ~/.gazebo/models/ \

If you do that you should get something like this, just tested locally:

Hi , Thank you, actually i was working on the online platform from construct. So will it be the same solutions?

This is the simulation loading on the online platform.

Thank you very much, i tried working with the riabot repo it worked!!

1 Like

Good to know it worked :wink: