T3_action_msg package not being found

In Unit 5 on ROS 2’s action tutorial, when I go to search for the t3_action_msg package which is stated to be found in the instruction list, the console says that the package is unknown to it. I have made sure to source it and tried deleting and re-compiling the build/ and devel/ folders it catkin_ws. I checked the ros2 interface list and package list and this package did not show up in either list. Is there anything else I can do or should I continue and not worry about doing these exercises?

Hi, welcome to the community!

If you are working with ROS2, then you should be using the ros2_ws. Deleting the build and devel folder in your catkin_ws won’t affect anything in the ROS2 environment. Make sure you compile under the correct workspace and source it afterwards.

Thank you for advice! Unfortunately, doing that did not work. The error I’m getting is exactly as follows:

[example52-1] from t3_action_msg.action import Move
[example52-1] ModuleNotFoundError: No module named ‘t3_action_msg’

The directory name I’m executing from is “ros2_ws”. How I’m executing it is as follows:

  1. colcon build --packages-select my_action_client
  2. source ~/ros2_ws/install/setup.bash
  3. ros2 launch my_action_client example52_launch_file.launch.py

Could it be something to do with my setup.py file not finding the packages and associated interfaces?


If you followed the instructions, then you should not have to modify anything from the setup.py. I just attempted the example in my computer and it worked correctly. Are you taking the Python or C++ course?

Hi again,

The python course. The ROS2 version specifically. Is there a way that I can reset the course? Perhaps there’s something wrong with the IDE.

Maybe you can try in a different browser, and loging out for a while?

The installed packages should be there every time the session starts, even if they get accidentally removed.