Terminals stuck and will not reset

I’m incredibly new to Linux and this seems like an oversight in the beginners Linux course on this site. Going into the second lesson the terminal is still running the bash from the first. The course doesn’t tell you how to exit. I google it, and as you can see in the photo I screw it up more. Now the first web shell is frozen because I can’t enter anything. It persists even if I refresh or exit and start again. So shell one is scorched-earth I guess, hope I don’t need it. I open shell two: still in the bash. Can’t do regular commands and I’m back to square one.

I’m a beginner, this is a course for beginners; hold my hand a little bit and tell me how to do basic tasks or at the very least let me reset the web shell in some way. This is a very frustrating roadblock to hit literally right out of the gate.

Hi @dominic.ciofalo,

Welcome to our community.

This shells-never-terminate “issue” is because we implemented a way of keeping the sessions, so that users wouldn’t lose any commands they type previously when reloading the page. But I see we forgot to consider the option when the user wants to forcibly refresh the shell.

What I can tell you is that when the roslaunch process dies, the shell is restarted as well as the simulation.

So to force a hard refresh, you can just kill roslaunch with:
rkill -9 -r roslaunch

There is also a button on the right side of the simulation that allows you to restart the simulation, which will also restart all the shells.

Please let us know if the problem persists even after following the steps I mentioned.


That seems to take care of it, thank you for the prompt and helpful response.

1 Like

I have a similar issue but the solutions described here didn’t work for me. Is there an alternative?

My shell got stuck when I tried to navigate through a man page using the ‘f’ key. (Probably a bug you guys will want to track)

I already tried to quit the man page with q, :q, Q, :Q and ZZ, but they don’t work. I also moved to another tab and tried to kill the stuck shell process, but that also didn’t work. The solutions described in this thread also didn’t work. Is there any other way to reset that shell?

Hi @renanrdaros,

yes, the platform was improved recently, so the solution proposed in July doesn’t work anymore.

At the moment, I’m afraid the “easiest” way would be to change to a different unit of the course that has a different simulation. That would force resetting the shells.

Related to the man command, we are aware that there is a bug with it. Some time ago we bypassed that problem but I see that now we have to solve it again.

I’ll work on that man problem. Soon it won’t happen anymore.