TF broadcast and Listener not working for my models in Gazebo

Hi again experts, @staff

I am curious to understand what I have done wrong…
I have completed with success the TF course, and now I read it again in order to complete my TF project.
Well I have spawned 2 differente models in my Gazebo (“basic_car”, “jibo2”) and a sdf model (“marcus”). I tried to broadcast the jibo2 pose and orientation using the which you used for turtlebot…I just changed the arguments. And then create a listener for my basic_car follow the jibo2 robot.
I tried first with the robots, because I don’t know if a robot follow or can be followed a model.sdf…
Whatever, I could not see the robot follow each other. I think my python scripts are correct, and the launch files which trigger them also…because I did not got an error message.
which is the error. if you could take a look on my rosject please: is named “TF_Project”

       My launch file is: **roslaunch car_description carro_basico.launch**
       Then later: roslaunch **car_description basic_car_follow_jibo2.launch**

should work but did not…unfortunately.

Thanks in advance

In my ws also did not work…there is something very strange…I put the dependence of turtle_tf_3d in Cmake list and package.xml…however It seems that this work just for the turtlebot models?

I don’t know why my model does not follow the other…
Because I used exactly the same scripts you provided in ROS Tf course…

I also tried to run the code which was ready in “Turtle_tf_3d” package…
but did not work:

I copied the meshes from this package to Gazebo’s meshes directorie…however I imagine
the problem is in my Gazebo…because I am seeing pseudo models on it (ghosts, which does not appear, just the name in get_world properties…)… Gazebo is telling me that that enormous white box is turtle1…hahahahah and turtle 2 is a spirit …however I launched the original launch from turtle_tf_3d pkg from your bitbucket (github)…
So is this the issue? How can I uninstall my Gazebo and reinstall it. Is this safety?
I think it is more interesting install the Gazebo 8 or 9 in my ros kinetic version. Or should I upgrade my ubuntu and install ros melodic?
Which is the best configuration you could suggest me to work with more real robots model (for example the prius car or the dbw_mkz car…etc? I am really exhausted in trying to spawn my models in gazebo.
In this way@staff I think this is the moment to understand what is going on in my gazebo and how can I fix this…thanks

I suspect I have lost some configuration in somewhere. Because previously I could command my man to walk in Gazebo…and now it is not possible…I have repeated for my model which @duckfrost has answered me in Human model. And then I could move a sdf inside Gazebo.
However I can’t do this anymore. I get this error:

What should I repair to make broadcast Tf possible again?
I think this is the main problem of don’t move and follow the models inside it…but not sure