Tf2_tools view_frames - No executable found

Hi The Construct Team,

I am on the ROS2 Basics in 5 Days Galactic (C++) course and I am getting this error:

user:~$ source /opt/ros/galactic/setup.bash
user:~$ ros2 run tf2_tools
No executable found

I tried to do sudo apt install ros-galactic-tf2-tools but that fails.

Output of sudo apt install
user:~$ sudo apt install ros-galactic-tf2-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 413 not upgraded.
Need to get 8388 B of archives.
After this operation, 0 B of additional disk space will be used.Err:1 focal/main amd64 ros-galactic-tf2-tools amd64 0.17.2-1focal.20210819.184515
  404  Not Found [IP: 80]
E: Failed to fetch
.20210819.184515_amd64.deb  404  Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Please fix this.


Hello @girishkumar.kannan ,

You don’t need to install anything, you have to run the command without the .py extension, like so:

ros2 run tf2_tools view_frames

I’ve already updated the notebook with this.

@albertoezquerro ,

Tried again. It works!


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.