The IDE doesn't load

I’m trying to open the training for "ROS Basics in 5 Days (C++) and it looks like everything loads but the IDE doesn’t no matter what browser I use or

times I restart the browser. Please see the attached screenshot.


Did you press also the reload button in the IDE window? If so, could you press F12 in your browser and record the messages that appear in the debugging console when you load the page? We might see something that might help clear up what’s happening here.

Which browser are you using?

We officially support only Chrome and Firefox at this time. Also, we have seen that the IDE might not work in “incognito” or private mode.

I’m using the latest version of Firefox on Mac and not using incognito mode. I have also tried to clear my cash and cookies, still no chance.

I have tried to reload the IDE and it didn’t work. Here is the log file with timestamps:

To provide a cleaner information, I cleared the log and hit “reload” on the editor and I got three error messages in the console (see the attached picture). It looks like the JS files it is looking for are not loading and it’s getting error 404: not found


Sorry to hear that. Have you tried in Chrome? Is just to discard that its not related to the browser.

1 Like

I just tried with Chrome and it worked! thanks for the suggestion.

1 Like