The manifest contains invalid XML

I am working on my quiz of the service unit.
While compiling the BB8Custom ServiceMessage, I am getting this error ('The manifest contains invalid XML)
Below is the the picture of my .xml file

Hi @VedantGonnade can you share the exact error message?

1 Like

This is the error

Hi @VedantGonnade

I’m sorry about this problem.

The error message says that the problem is on line 66, column 2, which has a mismatched tag. In the IDE, please trace the tags on that line and ensure the opening and closing tags are present.

If you cannot trace, please post the xml here. When posting, put a (```) on the first and lines, like this:

# your xml here

By the way, welcome to the community!

My problem is solved. :slight_smile: Thanks :slight_smile:

1 Like

Hi @VedantGonnade,

Great! Mind telling us how you solved it? :slightly_smiling_face:

I deleted the package ‘service_quiz’ and create everything again and edit cmake list file and .xml file again. It is working good now :slight_smile:

1 Like

I have another problem.

I am trying to do quiz from service part.

I am launching my server launch file. find below my code.
After calling it, I am getting side:0.0 and repetition:0.0. can you explain me why is this happening?

Hi @VedantGonnade,

Are you able to resolve this new problem too? If so, how did you resolve it?

If not, you just need to specify the actual values in place of the zeroes, which are default values auto filled by the autocompletion system.

Today, again I am getting errors during compile process. Please find below the pictures of my error ,cmakelist file and .xml file.

Hi @VedantGonnade,

I think you are making some typo in the CMakeLists.txt and package.xml files…could you please go over the steps again making sure there’s no typo and you have included the right things?

I will check for the typos. Can you please tell me what should I add in generate message() section of the Cmakelist file. I tried deleting generate message files from Cmakelist and the file was compiling without any problem but the .launch file was showing an error during launching.

I solved it. In the message, I was writing Int32, It was supposed to be int32, I should be small not capital. :stuck_out_tongue:

1 Like

Way to go @VedantGonnade. You rock!! :smile:

1 Like