Unable to connect with ROS master in real robot lab

This is the third time I have wasted my booking session trying to connect to the Real Robot Lab. I can turn the robot connection icon green. However, the gamepad does not initialize. Neither can I move the robot with the joystick nor see rostopic list. It says “unable to connect with ROS master.” Please help.

1 Like

Hi @cjans121 , I just checked the real robot and it looks like it ran without issues the whole weekend. Can you share a screenshot of the error next time you try to connect? I will give you two extra reservations this week.

Thank you and I apologize for the inconvenience

I’ve recorded this video so you can see how the process goes. Please let me know when you plan to connect again and I will walk you through it:

Hi @roalgoal, thanks for the gif. However, that is precisely what I did but couldn’t connect. Here are some images for your reference. Let me try it again today, and if I am unsuccessful, perhaps, you could help me out online? Thanks for the offer.

I had the same issue yesterday.

The ‘Are you sure you have a booking for now?’ came up for the first 10 minutes and it wouldn’t let me open a terminal. Once the stream showed up afterwards, I ran into the same ‘Unable to communicate with master!’ error for the rest of the session.

My first session was with the Robot Arm, but I tried again with the Turtlebot and had no luck with that either.

1 Like

Tried again. Same issues. Another half hour wasted. Could you please help me online? Thank you.

I am sorry you are still having connection issues. It seems like that error ‘Are you sure you have a booking for now?’ is causing an issue, but it doesn’t happen to every user. I will work on finding a solution and will personally make sure you can connect the next time.

Can I ask whether you are running a firewall in your network?
What browser are you using?

Again, I apologize for the issues

1 Like

Hi again @cjans121

We are working on replicating the issue, and I have tested the robot connection with no problems. It looks like the back end had some issues at the time and that might have cause the error, but that doesn’t explain the other times.

I want to be there for the next time you connect. Please let me know ahead of time when you plan to connect next, and I will walk you through it and identify any errors if they appear.

Once you have the time, please email me at rgonzalez@theconstructsim.com so we can set up a zoom call and solve your problem.

@roalgoal , I appreciate your support. I just have the Windows Defender Firewall and run the Brave browser. I’ll email you right away so we can setup a time for the Zoom call. Thanks again.

Please only use Firefox or Chrome. These are the browsers we support at this time.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.