Unable to view the generated map

I have generated a map. Now I want to use it for for localization. But when I use the map_server node and the amcl node, in rviz I cannot generate the map. The error I get in rviz is

No transform from [map] to [summit_xl_a_odom]

I realize no tf of map is being published, but how do we resolve the problem

I could be able to view the map by

rosrun tf static_transform_publisher 0.0 0.0 0.0 0.0 0.0 0.0 map summit_xl_a_odom 100

but when I start my amcl node, the laser scan is always moving and the particle clouds are at wrong position, even though the robot in gazebo simulation is still at the center even if the robot is still.
@staff can you please help me out as soon as possible, I am stuck on this project for a long time.

Hello @hrushikesh.kyathari,

You need to make sure you have the correct values for the following parameters:

odom_frame_id: summit_xl_a_odom
base_frame_id: summit_xl_a_base_footprint

Also, check that the velocity topics are remapped to /summit_xl_control/cmd_vel and the scan topics remapped to /hokuyo_base/scan.

I have updated the Project solution notebooks so that you can also check there how the files should be.


Thanks for the reply sir, I could get the amcl node running but when I use the move_base node, I am not able to visualize global or local cost maps.

When I used the solutions, I still get the same error. What am I doing wrong? Is it because I am messing up with remapping or frame_id names?

I fixed my problem, not sure what caused the error , just did everything again. Thanks a lot @albertoezquerro sir for your answer and patience with me