Unit 2 Not displaying correctly


The content beyond point 2.6 in Unit 2 is not displayed properly. I cannot complete the unit as displayed. (Using Firefox)

Hi, I have the same problem

@EQdAzc and @WangYizhe ,

From the description I understand that you must create a “launch” directory and create a launch file. That is very simple. The notebook/display error should not deter you.

To create a launch directory in your path do:
cd /path/to/directory
Then do following to create a launch directory.
mkdir launch
Then do following to create a launch file
cd launch
touch launch_file_name.launch

That’s all!

Hope I helped. Let me know if I did help.


1 Like

Hi Girish,

Thanks for your reply. However, the contents from 2.6 to the end of Unit 2 all don’t display correctly.

Thanks again!

Hi Girish,

To build on WangYizhe’s reply:
In 2.6 you are expected to start working with your first python program, starting by copying it from the file “simple.py”
But 1) the link to “simple.py” is broken, and 2) it is not findable anywhere else, because everything from 2.6 until the end of the unit doesn’t display.
The instructions are “Now, copy the content of simple.py into the new file.
You can’t quite do that when there is no text to copy.

Have you both tried switching your browsers, between Chrome / Firefox / Opera ? Maybe that will work.
Try to uninstall any plugins from your browser and try again!

I am just another student in this website. I had that issue once in one of the courses and I just reset my browser settings and it got fixed. Maybe it would work if you reset your browser.


Hello @EQdAzc ,

This error has been solved. Please note that it might take some minutes for the fix to show in the Academy.

This topic was automatically closed after 22 hours. New replies are no longer allowed.