Unpublished topic

I am using this package:

and I run these commands:
$ roslaunch niryo_one_bringup desktop_rviz_simulation.launch
$ rostopic echo /niryo_one/robot_state

On my ubuntu14 PC, I got the topic echoed and got the following:
x: 0.06957
y: 1.31e-12
z: 0.20077
roll: -5.103e-12
pitch: 0.757298
yaw: 5.1035e-12

and these values are correct. But if I do the same on your ros platform, I got the following:

WARNING: topic [/niryo_one/robot_state] does not appear to be published yet

and if I try to publish some msgs on the topic, then I get:

ERROR: Unknown topic /niryo_one/robot_state

so could you please help us with this problem?

Hi @amohtasib,

This indicates that the setup if the package is somehow incomplete, please go over it again.

It could be as simple as running source ~/catkin_ws/devel/setup.bash on the shell when you are running that command (after running catkin_make), or it could be that a required package or config is missing.

Hi @bayodesegun ,

Thank you for your reply.

I did run source ~/catkin_ws/devel/setup.bash and it works fine.

but the problem now is that I need to run this each time I run the ros project because the .bashrc file is automatically reset when I run the ros project. I tried to save the ros project before close it but this didn’t help.

Do you have any suggestion?

Hi @amohtasib,

I apologize for that inconvenience, but at this time we are not saving the .bashrc because of all the weird things that could happen when the wrong things get in there. We could consider it in the future.

OK I understand.

Thank you for your help.

1 Like