View_frames error

for the ROS Navigation in 5 Days Rosject I’ve deleted and reloaded my rosject. Things seem to run OK, however when I try to get visualize by transforms by running rosrun tf view_frames , I get the usual message about listening to /tf, and then done listening. However then I get the following error:

b'dot - graphviz version 2.43.0 (0)\n'
Traceback (most recent call last):
  File "/opt/ros/noetic/lib/tf/view_frames", line 119, in <module>
  File "/opt/ros/noetic/lib/tf/view_frames", line 89, in generate
    m =
TypeError: cannot use a string pattern on a bytes-like object

No pdf gets generated.

Any suggestions? I can live without it, but it might come in hand for future trouble-shooting.


Hello @comm ,

Could you try the following command?

rosrun tf2_tools


Pretty sure I tried that yesterday. Regardless I tried again - no luck. I get:
[rospack] Error: package 'tf2_tools' not found

Then run the following commands:

sudo apt update
sudo apt install ros-noetic-tf2-tools

Yes, that worked.