Virtual env: no such file or directory

I am Jacob, nice to meet you all and thanks for your work.
I am attending the Python3 for Robotics course but I am stuck at the beginning since when I try to create the virtual environment as reported in the course, the following error is returned:

Could you please help me on this? I cannot figure it out.

Thanks a lot!!


Exact same problem, looks like the link is broken due to a missing folder (catkin_ws_python3 folder is missing). Tried installing updates and virtualenv but it didn’t solved the problem.

source ~/.py3venv/bin/activate
this is the command provided in the instructions, but in forum the updated command is:
source ~/.catkin_ws_python3/bin/activate

updated one also have same problem

Also tried instruction from this thread:

@ralves sir, please look into this

Hello everyone,

Same problem also in the Python 3 for Robotics course.

@potto95 @Robots4Space_Bapt
After learning about virtual environments in python, I was able to create the missing virtual environment using the following sequence of commands:

sudo apt-get update
sudo apt-get install virtualenv
sudo mkdir -p /usr/local/share/venvs
sudo python -m virtualenv py3venv

Then run the command given in the instruction, this should works (worked for me)

source ~/.py3venv/bin/activate

1 Like

Hi @potto95, @irfan.mohd1503, @Robots4Space_Bapt,

I have been investigating and found that the problem is that the notebooks were updated to the wrong version.

I just reverted the notebook changes. Now they should work, not referring to the virtualenvs.

Thank you very much for letting us know about this issue and sorry for the inconvenience we may have caused.

Keep pushing your ROS Learning.


Hi @ralves , I am new to ROS, and I was following the course *
Using NVIDIA Jetson Nano with ROS

I was wondering if there is the same problem in the course too. Because when I tried to follow the instructions in Unit 1: Basics - Move Ignisbot. In the very first code for running in physical robot, I met the same code, and the error is just like above.

cd ~/catkin_ws/src
mkdir -p my_catkin_ws_python3/src
cd ~/catkin_ws/src/my_catkin_ws_python3
source ~/.py3venv/bin/activate

I am very new to ROS even coding, and here I found not many people are learning the same course with me. So I can get stuck easily, but I will try my best to keep learning. Thanks for your kind help.