Ardrone won't move while /cmd_vel echoes data

I’m trying to complete actions unit (Unit 9) in ROS Basics in 5 days (Python) course. The ardrone isn’t moving, while commands are being published on the topic /cmd_vel. Using the action server from unit 8 (roslaunch ardrone_as action_server.launch) and publishing goal.nseconds to any number, the drone still doesn’t move while taking pictures.
I’ve tried echoing /cmd_vel while the commands are being published and found that /cmd_vel echoes correct data, while the drone still doesn’t move.
In the follwing screenshot I was using the teleop_twist_keyboard to fly the drone, but it wont move, while cmd_vel topic shows a velocity being published in linear.z direction.

Hi @Yogesh_G ,

Did you send the command to takeoff and/or land the drone?

Before you make the drone move, you must first takeoff. And once you have played around by moving it, you must land.

The takeoff and land methods are explained in the course. Please follow those parts in the notes.


Hey @girishkumar.kannan , thanks for the suggestion!
I had given the command to take off, as indicated by the value of linear.z (0.53…) in the attached screenshot. The issue persisted even while using the already provided ardrone action server by TheConstruct. The drone didn’t move at all, as mentioned in my post. while it was supposed to take off and take pictures, it just took pictures but didn’t move.

Shouldn’t you take the drone off by publishing into /drone/takeoff or a similar topic? And land the drone by publishing to a similar /drone/land topic?

Check rostopic list to find out the right topics.