Controller Spawner couldn't find the expected controller_manager ROS interface


I completed the ROSControl101 course before successfully. Right now I am trying to write my own servo motor driver for ROS. For this, first I decided to try this course packages for better understanding. I downloded the rrbot_description, rrbot_control and rrbot_gazebo packages. I am using ROS Kinetic on Windows 10 WSL. When I try to launch rrbot_control, it throws “Controller Spawner couldn’t find the expected controller_manager ROS interface” warning. I checked everything but still can’t find the problem. Could you suggest me anything to check.

PS: I didn’t change the downloaded packages. So xacro and launch files have both same namespace which is rrbot. Also I am sure that all controll and gazebo packages are installed.
PS2: How I test it
roslaunch rrbot_gazebo main.launch -> this works fine
and then when I try following command
roslaunch rrbot_control rrbot_control.launch
I get Controller Spawner couldn’t find the expected controller_manager ROS interface


Unfortunately Gazebo is a bit osbcure with its errors. One common reason for that, is that you dont have all the controler types installed, so installing the gazebo-ros-control related packages could help.

Hello duckfrost, I already installed ros-control related packages ans also check them. We tried it on another computer with same code and it worked. But we don’t know why : ) Probably some missing library but it doesn’t say anything about problem. Thanks again.