Couldn't understand the following snippet

I tried running the commands in the following image but they show the errors as in the next image. I tried removing “urdf_course_exercises” but then the error is “Permission denied”. Please help me with the situation. Thanks.


The error indicates that the folder /home/user/catkin_ws/src/urdf_course_exercises/my_mira_description does not exist.

Can you check that the folder /home/user/catkin_ws/src/urdf_course_exercises/ exists and that the folder my_mira_description exists inside it.

Hi bayodesegun,
No, there is no folder called “urdf_course_exercises”. I understood that error part, hence removed that folder name from the directory path and tried again. But this time it showed “Permission denied”. So, tried google for the problem and figured out using “sudo” in the command. It worked but now when I launch the urdf file, it shows the following in the gazebo environment.

What could be the problem? Thanks!

@shiruraditya, did you copy the right meshes? The idea is that if you have modified the meshes, you need to copy them into the /usr/share/gazebo/models/ directory.

Hi @bayodesegun,
Yes, I copied the right meshes to the mentioned directory. Please let me know if I have done it wrong. The image shows the exact locations of meshes in the directory.

There is a problem in the academy why you cannot see the meshes. We are working right now on solving it. Let me send you a message when it is solved along with this morning