Cp: cannot create directory '/usr/share/gazebo/models/': Permission denied

cp: cannot create directory ‘/usr/share/gazebo/models/’: Permission denied.This error when I am running the command cp -r /home/user/catkin_ws/src/my_mira_description /usr/share/gazebo/models/

1 Like

Having the same problem. The models directory does not exist and I can’t create it

Me too… :frowning:

even i have the same problem.how did you people resolve it?

I’ve just updated the command to use the folder gazebo-7 instead of gazebo. Can you confirm if it works now?

I am not sure if anyone else got around this. However, I just tried it with gazebo-7 and I get the permission denied there too. Has anyone found a solution?

By the way, the version I am looking at does not have .the gazebo-7 in the notebook either. I am working with the Exercise 2.3 in unit 2 Using Urdf for gazebo.


I just tried it and it worked for me. The correct command is the one stated in the notebook, you might have an older version for some reason?:

sudo rm -rf /usr/share/gazebo-7/models/my_mira_description
sudo cp -r /home/user/catkin_ws/src/my_mira_description /usr/share/gazebo-7/models/

Then if you execute the spawn command it should work:

rosservice call /gazebo/delete_model “model_name: ‘mira’”
roslaunch my_mira_description spawn_mira_no_controllers.launch

Please tell me if it didn’t work

1 Like