Custum controllers of chapter 3 and 4 never working

I have a lot of problems with the costum controllers in the training environment. They always generate a fail to load error message even if i reset the web environment as prescribe.

I have installed locally both exercises in my computer and it is working perfectly.

Aldo it did to work at the first time and a have found a way to check that the cortrollers were ok using the following command.
rosservice call controller_manager/list_controller_types | grep “/PositionController”

   wich gave the following answer
          joint_state_controller/JointStateController, my_controller/PositionController, pos_vel_acc_controllers/JointTrajectoryController,  position_controllers/JointTrajectoryController, project_controller/PositionController,

When i have my controllers in that list, it can be loaded without problems

If i try to do the same thing in the web environement that the service is not working:
ERROR: Service [/controller_manager/list_controller_types] is not available.

Hello @fgenestcvdl,

First of all, thanks for your feedback. I’m looking into this issue and I will try to implement a fix as soon as possible. I will let you know once it’s solved.


1 Like

Hello @fgenestcvdl, we are happy to announce that this error has been finally solved. Thanks for you support and patience.