Errors when launch xacro firstly

I just start to try ‘xacro’ part in URDF course. I come with a problem when I run this code:

$ roslaunch my_gurdy_description spawn_gurdy_xacro.launch

the content of spawn_gurdy_xacro.launch is:

<?xml version="1.0" encoding="UTF-8"?>
<arg name="x" default="0.0" />
<arg name="y" default="0.0" />
<arg name="z" default="0.0" />

<arg name="robot_name" default="gurdy" />
<arg name="xacro_file_path" default="$(find my_gurdy_description)/robot/gurdy.xacro" />

<!-- Load the URDF into the ROS Parameter Server -->
<param name="robot_description" command="$(find xacro)/xacro $(arg xacro_file_path)" />

<!-- Run a python script to the send a service call to gazebo_ros to spawn a URDF robot -->
<node name="urdf_spawner" pkg="gazebo_ros" type="spawn_model" respawn="false" output="screen"
args="-urdf -x $(arg x) -y $(arg y) -z $(arg z)  -model $(arg robot_name) -param robot_description"/>

It shows errors like this:

[INFO] [1665156867.620585, 104.724000]: Spawn status: SpawnModel: Entity pushed to spawn queue, but spawn service timed out waiting for entity to appear in simulation under the name gurdy
[ERROR] [1665156867.623905, 104.727000]: Spawn service failed. Exiting.
[urdf_spawner-1] process has died [pid 28381, exit code 1, cmd /opt/ros/noetic/lib/gazebo_ros/spawn_model -urdf -x 0.0 -y 0.0 -z 0.0 -model gurdy -param robot_description __name:=urdf_spawner __log:=/home/user/.ros/log/3a7fb484-4655-11ed-9b04-0242c0a80007/urdf_spawner-1.log].
log file: /home/user/.ros/log/3a7fb484-4655-11ed-9b04-0242c0a80007/urdf_spawner-1*.log

But according to the notebook, it should have no errors.

Hi @MeineLiebeAxt,

this problem can occur when the XACRO file has an error. When the XACRO file has an error the parser gives this error and doesn’t spawn the model. The “queue error” is because the spawn node just send the model and waits for Gazebo to generate it in the simulation. But Gazebo can’t do that because of the error in the file, so it just says " waiting for entity to appear in simulation".

Try checking your XACRO file against the solutions version and see if you can spot any difference.



Thank you @rzegers . I reviewed my xacro-file and reboot the Gazebo, it is solved.

1 Like

This topic was automatically closed after 20 hours. New replies are no longer allowed.