Fail to load joint_position_controller

<updated - see reply below>

When working on Gurdy for the section 3 quiz, I got stuck with my joint position controllers not loading. Eventually I found this post:
where @simon.steinmann91 figured out it’s the namespace that was causing the problem.

I’m just wondering if anyone figured out why. I suspect most of us are heavily leveraging the code we used for the Mira model. The namespace doesn’t seem to be an issue for Mira (I just started Mira again to confirm). So why the problem with Gurdy?

I haven’t tried submitting the quiz yet because I expect the grading program expects the joint controllers in the gurdy namespace. Any suggestions?


First, the post I had linked to actually didn’t solve my problem. I thought it did because I got no more error messages saying it had failed to load the _joint_position_controller. But I didn’t check until today - there were still no joint position controller topics being published. So nothing was actually fixed.

Second, I FINALLY found my error. Despite repeatedly doing comparisons, somehow I missed including the “gurdy;”’ at the top of the gurdy_controllers.yaml file. Once I did, everything worked. I was sure it was something small like that, but just missed it repeatedly. I’m embarrassed, but hopefully this post will help some future student who has the same problem.

Apologies to anyone whose time I wasted with my earlier post.



Great to know its solved :wink:

1 Like